DIP 1020--Named Parameters--Community Review Round 2

Max Haughton maxhaton at gmail.com
Tue Sep 10 19:34:45 UTC 2019

On Tuesday, 10 September 2019 at 18:47:54 UTC, Jonathan Marler 
> On Tuesday, 10 September 2019 at 09:06:23 UTC, Mike Parker 
> wrote:
>> [...]
> Sorry in advance for the bikeshedding, but using the @ symbol 
> just looks ugly to me. How about using 'public' instead of 
> '@named'?
>     void foo(@named bool log, @named bool goFast);
> Vs.
>     void foo(public bool log, public bool goFast);

In fact, @public cannot compile as is so that might be a better 
solution still (bare "public" might require modifying the parser 
more but it's not my expertise)

More information about the Digitalmars-d mailing list