DIP 1020--Named Parameters--Community Review Round 2

Jonathan Marler johnnymarler at gmail.com
Tue Sep 10 19:50:44 UTC 2019

On Tuesday, 10 September 2019 at 19:34:45 UTC, Max Haughton wrote:
> On Tuesday, 10 September 2019 at 18:47:54 UTC, Jonathan Marler 
> wrote:
>> On Tuesday, 10 September 2019 at 09:06:23 UTC, Mike Parker 
>> wrote:
>>> [...]
>> Sorry in advance for the bikeshedding, but using the @ symbol 
>> just looks ugly to me. How about using 'public' instead of 
>> '@named'?
>>     void foo(@named bool log, @named bool goFast);
>> Vs.
>>     void foo(public bool log, public bool goFast);
> In fact, @public cannot compile as is so that might be a better 
> solution still (bare "public" might require modifying the 
> parser more but it's not my expertise)

Yes using `public` would require a grammar change.  However, the 
feature requires other grammar changes as well.  Also, using 
either `public` or `@named` without the feature will result in 
compilation errors so they're both on the same level in that 

More information about the Digitalmars-d mailing list