DIP 1020--Named Parameters--Community Review Round 2
rikki at cattermole.co.nz
Wed Sep 11 05:15:04 UTC 2019
On 11/09/2019 6:47 AM, Jonathan Marler wrote:
> Sorry in advance for the bikeshedding, but using the @ symbol just looks
> ugly to me. How about using 'public' instead of '@named'?
> void foo(@named bool log, @named bool goFast);
> void foo(public bool log, public bool goFast);
I considered this quite some time ago.
It works for templates, but it does not work for functions.
I have also considered @property, which would also look ok for templates
and functions but would be rather long.
Right now @named is the best of possible syntaxes given the semantics
which have been proposed IMHO.
More information about the Digitalmars-d