DIP 1020--Named Parameters--Community Review Round 2
rikki at cattermole.co.nz
Wed Sep 11 16:26:32 UTC 2019
On 12/09/2019 4:08 AM, Jonathan Marler wrote:
> On Wednesday, 11 September 2019 at 05:15:04 UTC, rikki cattermole wrote:
>> On 11/09/2019 6:47 AM, Jonathan Marler wrote:
>>> Sorry in advance for the bikeshedding, but using the @ symbol just
>>> looks ugly to me. How about using 'public' instead of '@named'?
>>> void foo(@named bool log, @named bool goFast);
>>> void foo(public bool log, public bool goFast);
>> I considered this quite some time ago.
>> It works for templates, but it does not work for functions.
> Why wouldn't it work for functions?
Syntactically and semantically there is no reason for it to not work.
It comes down to personal preference. To me it means that there is some
sort of semantic associated with functions and their named parameters
like there is with templates when there isn't.
More information about the Digitalmars-d