DIP 1029---Add throw as Function Attribute---Community Review Round 1

Joseph Rushton Wakeling joseph.wakeling at webdrake.net
Tue Jan 14 15:04:59 UTC 2020

On Tuesday, 14 January 2020 at 11:53:17 UTC, IGotD- wrote:
> I was originally for that we should use the "throws" keyword in 
> order to make it more searchable. However, now when I see the 
> solution and that "nothrow" will still remain I think that 
> "throw" is better for symmetry with "nothrow".

On that specific note, perhaps the DIP author can include some 
code search strategies to differentiate between (i) functions 
marked `throw` and (ii) lines of code where an exception is 
thrown ... ?

It's minor, but it would be a nice consideration to folks whose 
search rules-of-thumb might be thrown out of whack by this change.

More information about the Digitalmars-d mailing list