Discussion Thread: DIP 1037--Add Unary Operator ...--Community Review Round 1

Ola Fosheim Grøstad ola.fosheim.grostad at gmail.com
Sun Nov 1 10:45:48 UTC 2020

On Sunday, 1 November 2020 at 10:15:44 UTC, claptrap wrote:
> To me "alias sequence" is an implementers name, it's named for 
> how it's implemented not for the actual concept.

Yes, but tuples should have struct semantics, and structs hold 
values, not aliases.

Anyway, this would all become moot if the ... operator was 
designed to work with all static length objects that provide 
index-access and .length.

More information about the Digitalmars-d mailing list