two semantic change proposals

Steven Schveighoffer schveiguy at yahoo.com
Tue Apr 21 05:21:05 PDT 2009


On Tue, 21 Apr 2009 07:58:32 -0400, davidl <davidl at nospam.org> wrote:

> I believe the following allow the runtime reflection wrapper. Though it  
> changes the old semantics, the old one can be implemented on top of the  
> new semantics
>
> http://d.puremagic.com/issues/show_bug.cgi?id=2868
>
>


That's cool.

However, you have misunderstood how the opDot function name should be  
passed via templates.

The opDot signature should not take a type as the first argument, but a  
string.  Otherwise, you have no compile-time abilities with the function  
name:

opDot(string methodname, T...)(T args)

instead of

opDot(U:immutable(char)[], T...)(U methodname, T args)

-Steve



More information about the Digitalmars-d mailing list