renamepalooza time
Jonathan M Davis
jmdavisProg at gmx.com
Fri Jan 21 11:52:43 PST 2011
On Friday, January 21, 2011 06:04:53 spir wrote:
> On 01/21/2011 09:44 AM, Jonathan M Davis wrote:
> > Well, entab, I'd argue_does_ follow the naming convention, because entab
> > would be a verb, albeit a made up one. Certainly, en is a prefix, not
> > another word, so I think that entab is fine. If that doesn't fly, then
> > go with enTab, I guess, but I'd argue that entab is a single word and
> > fine as it is.
>
> I fully agree with you on the linguistic side: "entab" is a single-word
> term, just like eg "input" (no-one would suggest "inPut" ;-). But
> practically, the decomposition "enTab" helps understanding this
> identifier by nicely highlighting "tab", don't you think?
> This is even more relevant for foreigners, who have here to guess: (1)
> that "entab" is not a 'normal' english single-word term they would just
> not know (2) as you say, that en- is a verb-forming prefix in english
> one can more or less freely use. Non-trivial.
I'm afraid that I don't agree at all. enTab is hideous and arguably confusing
precisely because en is _not_ a word. I'd start trying to figure out what en was
short for if I saw an enTab function. entab is _far_ clearer. Would you make a
function named enClose? I should hope not. Granted, enclose is actually a word
that you'll find in a dictionary, but en is a normal prefix in English, and trying
to treat it as a word or abbrevation in function names would just be confusing.
- Jonathan M Davis
More information about the Digitalmars-d
mailing list