renamepalooza time
Ali Çehreli
acehreli at yahoo.com
Sun Jan 23 00:13:08 PST 2011
spir wrote:
> On 01/23/2011 12:03 AM, Ali Çehreli wrote:
> Sounds similar to
> using whitespace for visual grouping like in
> a*b + c*d
> or
> [ [1,2,3] , [4,5,6] ]
>
> But may be a bit too complicated for a public, free-willing, style,
> don't you think? Rather for an enforced project or corporate one, I'd
> say...
Agreed, but I will keep using an underscore after "is". Another reason
why I do so is, when used with camelcase, that little "is" capitalizes
the next word just to be consistent with the camelcase part of the
naming conventions. When we have an attribute of an object named
'ready', 'isReady()' doesn't match because 'ready' doesn't match
'Ready'. An underscore makes it stay lowercased:
is_ready();
The attribute can follow the camelcase rule and be consistent with the
rest of the names:
is_lastItem();
Ali
More information about the Digitalmars-d
mailing list