renamepalooza time
spir
denis.spir at gmail.com
Sun Jan 23 02:45:36 PST 2011
On 01/23/2011 09:13 AM, Ali Çehreli wrote:
> Agreed, but I will keep using an underscore after "is". Another reason why I do
> so is, when used with camelcase, that little "is" capitalizes the next word
> just to be consistent with the camelcase part of the naming conventions. When
> we have an attribute of an object named 'ready', 'isReady()' doesn't match
> because 'ready' doesn't match 'Ready'. An underscore makes it stay lowercased:
>
> is_ready();
>
> The attribute can follow the camelcase rule and be consistent with the rest of
> the names:
>
> is_lastItem();
You're right, it's a nice convention.
Deins
--
_________________
vita es estrany
spir.wikidot.com
More information about the Digitalmars-d
mailing list