Decision on container design
bearophile
bearophileHUGS at lycos.com
Sat Jan 29 09:15:21 PST 2011
Simon Buerger:
> * container should be named with respect to their use, not the
> implementation. "HashSet" is a bad name, because the user shouldnt
> care about the implemenation.
This is good for a language like Python, or even Java, but for a system language I want to know the algorithms I'm using under the hood. So I am not sure.
Bye,
bearophile
More information about the Digitalmars-d
mailing list