Decision on container design

Jim bitcirkel at yahoo.com
Sat Jan 29 10:44:52 PST 2011


bearophile Wrote:

> Simon Buerger:
> 
> > * container should be named with respect to their use, not the 
> > implementation. "HashSet" is a bad name, because the user shouldnt 
> > care about the implemenation.
> 
> This is good for a language like Python, or even Java, but for a system language I want to know the algorithms I'm using under the hood. So I am not sure.

There could be an interface named Set and various implementations of it, e.g. HashSet. I think this would be a good principle in general for all abstract collection types.


More information about the Digitalmars-d mailing list