std.unittests [updated] for review
spir
denis.spir at gmail.com
Mon Jan 31 11:20:56 PST 2011
On 01/30/2011 01:13 PM, Jens Mueller wrote:
> I do not like putting it in std.exception. Maybe the name std.unittest
> is also not good. I would propose std.assert if assert wasn't a keyword.
> [...]
I would_not_ expect helpers for writing
> assertions (Assert_Error_) in a module named std.exception.
Same for me. Find it strange. Would never search assertion helper funcs inside
std.exception. Why not std.assertion? std.unittests would be fine if there were
some more stuff in there, I mean not only assertions. Else, the obvious name
imo is std.assertion.
Denis
--
_________________
vita es estrany
spir.wikidot.com
More information about the Digitalmars-d
mailing list