"body" keyword is unnecessary
Nick Sabalausky
a at a.a
Thu Mar 24 13:34:55 PDT 2011
"Sönke Ludwig" <ludwig at informatik.uni-luebeck.de> wrote in message
news:imeqnd$12ss$1 at digitalmars.com...
> I'm all for this change.
>
> Since there are already similar differences between 1.0 and 2.0 (e.g.
> invariant()) and projects can be fixed by a more or less simple search and
> replace, this would be a cheap way to clean up a keyword that can truly
> get in your way (in contrast to some others that have already been
> removed).
>
> Actually I think the only keywords that really got in my way were "body"
> and "function" - I now have modules named body_.d and function_.d
I've had "unittest", "mixin" and "in" get in the way (but not in any way
that was actualy a real problem, just a minor *minor* inconvenience).
More information about the Digitalmars-d
mailing list