std.d.lexer: pre-voting review / discussion

H. S. Teoh hsteoh at
Wed Sep 11 13:07:22 PDT 2013

On Wed, Sep 11, 2013 at 10:04:20PM +0200, Dicebot wrote:
> On Wednesday, 11 September 2013 at 19:58:36 UTC, H. S. Teoh wrote:
> >I disagree. I think it's more readable to use a consistent prefix,
> >like kw... or kw_... (e.g. kw_int, kw_return, etc.), so that it's
> >clear you're referring to token types, not the actual keyword.
> Not unless you want to change the style guide and break existing
> Phobos code ;)

How would that break Phobos code? Phobos code doesn't even use
std.d.lexer right now.


Being able to learn is a great learning; being able to unlearn is a greater learning.

More information about the Digitalmars-d mailing list